iOS/Android Device Requirements for Microsoft Office 365

The following are the requirements for iOS and Android devices for Microsoft Office 365 Outlook:

  • iOS
    • The Microsoft Outlook app is only supported on the two most recent versions of iOS.
    • Native email app requires iOS 11 or higher.
    • Any 3rd party mail app that supports Modern Authentication – Not supported by ITS.
  • Android
    • The Microsoft Outlook app requires Android 5.1 Lollipop or higher. 
    • Any 3rd party mail app that supports Modern Authentication – Not supported by ITS
100% helpful - 1 review

Details

Article ID: 1470
Created
Thu 10/18/18 3:56 PM
Modified
Mon 12/2/19 3:48 PM